summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorRoland Reichwein <mail@reichwein.it>2025-01-20 21:56:53 +0100
committerRoland Reichwein <mail@reichwein.it>2025-01-20 21:56:53 +0100
commit2c5684482c14764cec4fb32b2ec07dd3f77fd4bf (patch)
tree9ff9c5c04a20c30568f4ce1c466fe55818a0b45b /debian
parent5fd637644c7529bfdc5291215f3f8ee1edd304c4 (diff)
Add click-fcgi (WIP)HEADmaster
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rw-r--r--debian/nginx-sites-available22
2 files changed, 24 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index de141e8..b95f2c8 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: click
Section: sound
Priority: optional
Maintainer: Roland Reichwein <mail@reichwein.it>
-Build-Depends: debhelper, clang, libc++-dev, libreichwein-dev, libasound2-dev, libfmt-dev, libboost-all-dev, libevdev-dev
+Build-Depends: debhelper, clang, libc++-dev, libreichwein-dev, libasound2-dev, libfmt-dev, libboost-all-dev, libevdev-dev, libfcgi-dev
Standards-Version: 4.5.0
Homepage: http://www.reichwein.it/click/
Package: click
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, spawn-fcgi, nginx, alsa-utils
Homepage: http://www.reichwein.it/click/
Description: Software system for MIDI Click
MIDI Click is a combined hardware-software solution to generate an audio
diff --git a/debian/nginx-sites-available b/debian/nginx-sites-available
new file mode 100644
index 0000000..f1ca5a1
--- /dev/null
+++ b/debian/nginx-sites-available
@@ -0,0 +1,22 @@
+server {
+ listen 80 default_server;
+ listen [::]:80 default_server;
+
+ root /usr/lib/clock/html;
+
+ # Add index.php to the list if you are using PHP
+ index index.html index.htm index.nginx-debian.html;
+
+ server_name _;
+
+ location ~ \.fcgi {
+ include fastcgi_params;
+ fastcgi_pass 127.0.0.1:9090;
+ }
+
+ location / {
+ # First attempt to serve request as file, then
+ # as directory, then fall back to displaying a 404.
+ try_files $uri $uri/ =404;
+ }
+}