summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/click.service19
-rw-r--r--debian/control1
2 files changed, 20 insertions, 0 deletions
diff --git a/debian/click.service b/debian/click.service
new file mode 100644
index 0000000..90617fe
--- /dev/null
+++ b/debian/click.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=Click
+After=network.target
+
+[Service]
+Type=simple
+# Restart=always
+ExecStart=click
+
+# Restart once a week, maybe certificates have changed
+Restart=always
+RuntimeMaxSec=604800
+
+# webserver will lower privileges to www-data:www-data
+#User=www-data
+#Group=www-data
+
+[Install]
+WantedBy=multi-user.target
diff --git a/debian/control b/debian/control
index 32b713a..de141e8 100644
--- a/debian/control
+++ b/debian/control
@@ -22,3 +22,4 @@ Description: Software system for MIDI Click
.
Supported Hardware platforms:
- Raspberry Pi 3 B+
+ - Raspberry Pi 4 B